MonteCarloSS.com
Previous Thread
Next Thread
Print Thread
#1051552 - 06/17/17 11:30 PM Weird Electrical Issues  
Joined: Apr 2017
Posts: 20
Alonzo Offline
Junior Member
Alonzo  Offline
Junior Member

Joined: Apr 2017
Posts: 20
Oakland,CA
Hi! I been having some weird electrical issues lately. The first being that my left turn signal doesn't flash in and outside of the car when my lights are on but manages to stay completely lit up in the cluster and works just fine when the lights are off but yet my right turn signal is completely functional. The second is that my high beams do not work at all, I replaced the bulbs and when I use my turn signal lever to engage the high beams they do not turn on but then again my wipers do not start when I use the lever. Any tips on how to get to the wiring of the lever and fix it? If the wipers still do not work after I fix the wiring on the lever, what would be cause of its failure? Finally my third and final issue is that my tachometer is reading completely wrong and the speedometer is jumping constantly and fails to accurately read my speed. Thank you in advance I appreciate all your help guys!!

#1051553 - 06/17/17 11:42 PM Re: Weird Electrical Issues [Re: Alonzo]  
Joined: Apr 2017
Posts: 20
Alonzo Offline
Junior Member
Alonzo  Offline
Junior Member

Joined: Apr 2017
Posts: 20
Oakland,CA
Also my cluster lights do not work at all but I think this is just simply bulbs.

#1051555 - 06/18/17 01:47 AM Re: Weird Electrical Issues [Re: Alonzo]  
Joined: Dec 1999
Posts: 11,183
86ttop Offline
15+ Year
86ttop  Offline
15+ Year
Member

Joined: Dec 1999
Posts: 11,183
Brooksville, Fl
some of your light problems are most likely tied to poor grounds, the dash lights may simply be bulbs, good luck!!


Leo Paugh
It's not an attitude, it's just the way I am.
POW*MIA
You are not forgotten
If things improve with age, I must be approaching magnificent. thumbs
#1051557 - 06/18/17 04:41 AM Re: Weird Electrical Issues [Re: 86ttop]  
Joined: Apr 2017
Posts: 20
Alonzo Offline
Junior Member
Alonzo  Offline
Junior Member

Joined: Apr 2017
Posts: 20
Oakland,CA
The grounds that are connected to the looms of the headlights? I checked those and they are fine

#1051565 - 06/18/17 05:51 PM Re: Weird Electrical Issues [Re: Alonzo]  
Joined: Mar 2000
Posts: 5,095
upflying Offline
15+ Year
upflying  Offline
15+ Year
Member

Joined: Mar 2000
Posts: 5,095
Reno, NV
You might want to invest in this manual. It will explain exactly how to chase down your electrical problems, step by step. It also has very clear wiring diagrams, I wore my manual out during my LS swap. Could be the best $8 you ever spent.
And welcome to the forum, I grew up in Oakland, Skyline High School, class of 1972.
http://www.ebay.com/itm/1988-GM-Chevy-Monte-Carlo-Caprice-Electrical-Diagnosis-Supplement-Manual-OEM-/352086140396?hash=item51f9f825ec:g:J1UAAOSwajVUOZV-&vxp=mtr


86 MCSS Notchback coupe, LS3, 4L65E, column shift, silver with maroon bench interior

#1051571 - 06/19/17 12:01 AM Re: Weird Electrical Issues [Re: Alonzo]  
Joined: Jun 2016
Posts: 239
ChasUno Online content
Member
ChasUno  Online Content
Member

Joined: Jun 2016
Posts: 239
Bradenton, FL
Lights - almost certainly an earth issue by what you describe.
Wipers - possible switch, motor failure or another possible bad earth (time to get that multimeter out!)
Tachometer - A known issue where part of the diode pack fails with age and the tacho become more and more inaccurate, to the point where they stop working or peg out. This thread shows you how to fix it:

http://www.montecarloss.com/community/ubbthreads.php?ubb=showflat&Number=1051121#Post1051121

Speedo - it's mechanical, so either a dry/ worn cable, or the speedo head itself is faulty. Likely the cable.

As upflying says above, grab the electrical supplement manual. It's worth its weight in gold.

Last edited by ChasUno; 06/19/17 12:02 AM.

1986 Monte Carlo SS

[Linked Image]
#1051753 - 06/24/17 02:17 PM Re: Weird Electrical Issues [Re: Alonzo]  
Joined: Nov 2012
Posts: 1,156
Ole Blue Offline
Member
Ole Blue  Offline
Member

Joined: Nov 2012
Posts: 1,156
Lugoff, SC
Alonzo, did you get your issues resolved you described in the first 2 posts above?

#1051763 - 06/24/17 07:50 PM Re: Weird Electrical Issues [Re: Ole Blue]  
Joined: Apr 2017
Posts: 20
Alonzo Offline
Junior Member
Alonzo  Offline
Junior Member

Joined: Apr 2017
Posts: 20
Oakland,CA
Time has been slim lately since I work full time and am a full time student but it's coming along little by little, thank you for asking! Another thank you to the people who have replied, it's been a tremendous amount of help!

#1051784 - 06/25/17 11:24 PM Re: Weird Electrical Issues [Re: Alonzo]  
Joined: Nov 2012
Posts: 1,156
Ole Blue Offline
Member
Ole Blue  Offline
Member

Joined: Nov 2012
Posts: 1,156
Lugoff, SC
Sounds busy!
I was asking in case you were stumped on any of the electrical and was still needing help/advice. If you do, I was willing to offer some input for you. I fought a few myself to keep mine running through the years.
Let us know how you make out or if you need any more help.


Help MonteCarloSS.com


Site Maintenance Fund
Contributors this
Past Month


FrankOC

Random Images
684/thumbs/montess_boxed_lower_control_arms.JPG
by 88ss87ss
500/thumbs/cowl_hood_002.jpg
by GearedSS
563/thumbs/l_965c4a0b9143b5a16acb28d848ca490f.jpg
by WhiteMonteSS
500/thumbs/Picture_0117.jpg
by 85MONTE!!
681/thumbs/complete_console.jpg
by TPI Monte SS
Authorized Vendors
Tell them you saw it
on MonteCarloSS.com!


CustomMonteSSParts.com
Dixie Monte Carlo Depot
GSI Interiors
HRpartsNstuff
Mikes Montes
Savitske Classic & Custom
Powered by UBB.threads™ PHP Forum Software 7.6.0