MonteCarloSS.com
MonteCarloSS.com

CELEBRATING 20 YEARS!

Previous Thread
Next Thread
Print Thread
#913878 - 01/19/12 04:29 PM 4.3l detonation problem  
Joined: Oct 2002
Posts: 542
Dark Ember Offline
10+ Year
Dark Ember  Offline
10+ Year
Member

Joined: Oct 2002
Posts: 542
Houston, TX
Heya fellow ss'ers. I have a problem with my 92' 4.3L S10. I am asking on these forums because I get better tech advice on this forum than on other forums I am a member of. We have a good knowledge base here. smile

That said, here is the problem. I set the timing on my S10 to 0 BTDC, the factory spec. Incase you are wondering, yes I disconnected the "set timing" connector before starting the engine to set the timing. Then reconnected it after shutting it off. I did not clear the EST code before test driving though. After doing nothing else, a bad detonation started at WOT in the upper rpm's. I put a tech 1 on it so I could monitor detonation and started retiming it. I set base timing to 4 BTDC and the detonation was even worse. Then I set to 2 ATDC, and the detonation was better but still audible. Then I set it to 4 ATDC and could no longer hear detonation. The tech 1 still said I had it though. Whats going on guys?

Last edited by Dark Ember; 01/19/12 04:31 PM.

88'SS Installing: 355 w/8.3:1 comp. expecting 440hp. T56, Eaton posi. 4.10's, 2" drop F/R. Full suspension upgrades. Boost and/or N20 is next, Then expecting 640-750hp.
#914281 - 01/21/12 08:04 AM Re: 4.3l detonation problem [Re: Dark Ember]  
Joined: Jul 2010
Posts: 81
MADMIKE Offline
Member
MADMIKE  Offline
Member

Joined: Jul 2010
Posts: 81
C.V. CA
I used to have a '92 TBI 4.3 S10. Never had detonation problems with it.
Are the spark plugs the correct heat range? Are they oil fouled?
Compression/Leak down test check out OK?
Coolant topped off? No leaks internal or external?
How is the fuel flow from the injectors, is it a good spray or is it spurting and dribbling?
Check the timing chain, pop off the distributor cap turn the crank to O* then turn it backwards until you see the distributor rotate. More than 5* I would look into replacing the timing set.

The only three issues I ever had with my S10 was the ignition pickup coil in the distributor went bad(would cause a miss when warm), rear shocks went bad(bad wheel hop) and the rubber engine mounts were too soft(replaced with ES mounts).


-Michael
Where the hell is JMD?!

Random Images
500/thumbs/stein07_01.jpg
by GregK
500/thumbs/indo_black_006.jpg
by Hailhorror77
500/thumbs/montedecaled_001.JPG
by Monster
500/thumbs/0711111820.jpg
by tetamcssmokin
500/thumbs/DSCN3990.JPG
by Aeroaddict
Help MonteCarloSS.com


Recent Contributors
86BlackSuperSport
dns87ss
Authorized Vendors
Tell them you saw it
on MonteCarloSS.com!


CustomMonteSSParts.com
Dixie Monte Carlo Depot
GSI Interiors
HRpartsNstuff
Mikes Montes
Savitske Classic & Custom
Powered by UBB.threads™ PHP Forum Software 7.6.0