MonteCarloSS.com

Printed Circuit install question

Posted By: abn2060

Printed Circuit install question - 06/08/19 12:42 PM

I have the PC almost installed on my 88 SS gauge cluster but there is one connection I’m not sure about. I took pictures before I took tho old one off but this area was not clear in the photo. Is there an attachment here or no? I can’t figure out how to attach pictures on this site so below is a link to the picture. Thanks

https://www.dropbox.com/s/ig7vjfii6220bk0/Photo%20Jun%2008%2C%208%2010%2037%20AM.jpg?
dl=0
Posted By: abn2060

Re: Printed Circuit install question - 06/08/19 12:46 PM

[img]https://www.dropbox.com/s/ig7vjfii6220bk0/Photo%20Jun%2008%2C%208%2010%2037%20AM.jpg?dl=0[/img]
Posted By: mmc427ss

Re: Printed Circuit install question - 06/09/19 01:30 AM

Can't get those links to work. More info if possible.
The only place there would be a non-connection would be under the two screws that are located at the back of the tach mount.
Bob
Posted By: Bitflipper

Re: Printed Circuit install question - 06/09/19 02:03 AM

Working link to image

I believe the image cannot be inlined because it's https. Try clicking this link.
Posted By: mmc427ss

Re: Printed Circuit install question - 06/09/19 05:40 AM

Thanks, it worked.
That hole in the circuit board should have no connection.
Bob
Posted By: abn2060

Re: Printed Circuit install question - 06/09/19 09:57 PM

After looking at it again yesterday there was only plastic underneath the PC so I figured nothing attached there. I got the car with the dash already out so it took a while to figure out how everything went back together and works. Well except the tachometer. Luckily none of the screws, clips and parts were missing so the job is done and at least drivable now.

Hope this link works.

www.dropbox.com/s/rqkpxqtvgakbiwq/Photo%20Jun%2008%2C%203%2054%2026%20PM.jpg?dl=0
Posted By: T5montecarlo

Re: Printed Circuit install question - 06/11/19 12:45 PM

Looks very nice. I have my cluster out right now to clean PC contacts and to repair the tach.
Posted By: abn2060

Re: Printed Circuit install question - 06/12/19 10:48 AM

Originally Posted by T5montecarlo
Looks very nice. I have my cluster out right now to clean PC contacts and to repair the tach.



I’ll sort out the tack at a later date. Have a lot more pressing issues to sort out. Mainly the t-too weatherstripping.
Posted By: T5montecarlo

Re: Printed Circuit install question - 06/12/19 11:51 AM

The back of the cluster housing has a hole that aligns with the unused trace on the printed circuit. On the cluster housing, the hole is marked "Batt". I suspect is a battery source for the clock that was at the bottom of the tach up to 1985.
Posted By: abn2060

Re: Printed Circuit install question - 06/21/19 09:30 PM

Originally Posted by T5montecarlo
The back of the cluster housing has a hole that aligns with the unused trace on the printed circuit. On the cluster housing, the hole is marked "Batt". I suspect is a battery source for the clock that was at the bottom of the tach up to 1985.


Possibly. By the looks of the old printed circuit it wasn’t used.
© 2019 MonteCarloSS.com Message Board